On Wed, Jul 28, 2010 at 11:29 PM, Aaron Sherman <a...@ajs.com> wrote:
> The more I look at this, the more I think ".." and "..." are reversed. ".."
> has a very specific and narrow usage (comparing ranges) and "..." is
> probably going to be the most broadly used operator in the language outside
> of quotes, commas and the basic, C-derived math and logic ops. Many (most?)
> loops will involve "...". Most array initializers will involve "...". Why
> are we not calling that ".."? Just because we defined ".." first, and it
> grandfathered its way in the door? Because it resembles the math op? These
> don't seem like good reasons.
I was thinking the same. Switching them seems better from a huffmanization POV.