On Sun, Nov 21, 2010 at 8:10 PM, Itagaki Takahiro <[email protected]> wrote: > On Wed, Oct 20, 2010 at 01:36, Dimitri Fontaine <[email protected]> > wrote: >> Ah yes, thinking it's an easy patch is not helping. Please find attached >> a revised version of it. > > I checked cfparser.v2.patch. > > It exports the static parseRecoveryCommandFileLine() in xlog.c > as the global cfParseOneLine() in cfparser.c without modification. > > It generates one warning, but it can be easily fixed. > cfparser.c:34: warning: no previous prototype for 'cfParseOneLine' > > Some discussions about the patch: > > * Is "cf" the best name for the prefix? Less abbreviated forms might > be less confusable. Personally, I prefer "conf". > > * Can we export ParseConfigFile() in guc-file.l rather than > parseRecoveryCommandFileLine()? It can solve the issue that unquoted > parameter values in recovery.conf are not recognized. Even if we > won't merge them, just allowing unquoted values would be useful.
I'd really like to see postgresql.conf and recovery.conf parsing merged, and I suspect, as Itagaki-san says, that postgresql.conf parsing is the better model for any new code. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list ([email protected]) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers
