Dimitri Fontaine <dimi...@2ndquadrant.fr> writes: > Tom Lane <t...@sss.pgh.pa.us> writes: >> But contrib/spi is exactly the case where it *won't* work. We need to >> somehow figure out that $libdir/autoinc is what to substitute in >> autoinc-1.0.sql, $libdir/insert_username in insert_username-1.0.sql, >> etc.
> Indeed. That's why I'm proposing to have that setup in the control > file, which is per extension, rather than in the common Makefile. How's that help? In a makefile building more than one extension, you'd still need a way to decide which extension the current script file is associated with. Or are you suggesting substituting for MODULE_PATHNAME during CREATE EXTENSION, and not during "make" at all? That would work I guess. I'm hesitant to have any substitutions that happen unconditionally, but we could add a control parameter like module_pathname = '$libdir/hstore' and then things would be pretty clean. I think we should still change the file naming conventions to use double dashes, though, since there's more than one reason to want that. Will work on that next. regards, tom lane -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers