On Mon, Sep 23, 2013 at 7:03 PM, Peter Geoghegan <p...@heroku.com> wrote:

> On Mon, Sep 23, 2013 at 9:54 AM, Andres Freund <and...@2ndquadrant.com>
> wrote:
> > I still find it wierd/inconsistent to have:
> > * pg_receivexlog
> > * pg_recvlogical
> > binaries, even from the same source directory. Why once "pg_recv" and
> > once "pg_receive"?
> +1

Digging up a really old thread since I just got annoyed by the inconsistent
naming the first time myself :)

I can't find that this discussion actually came to a proper consensus, but
I may be missing something. Did we go with pg_recvlogical just because we
couldn't decide on a better name, or did we intentionally decide it was the

I definitely think pg_receivelogical would be a better name, for
consistency (because it's way too late to rename pg_receivexlog of course -
once released that can't really chance. Which is why *if* we want to change
the name of pg_recvxlog we have a few more days to make a decision..)

 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/

Reply via email to