Andres Freund <and...@anarazel.de> writes: > On 2016-03-29 12:28:40 -0400, Tom Lane wrote: >> My proposal would be to invent a new elevel macro, maybe LOG_ONLY, >> for this purpose. But under the hood it'd be the same as COMMERROR.
> A couple years back I proposed making thinks like COMERROR into flags | > ed into elevel, rather than distinct levels. I still think that's a > better approach; and it doesn't force us to forgo using distinct log > levels. If we invent LOG_ONLY (feel free to bikeshed the name), we could later redefine it as (LOG | ERR_HIDE_FROM_CLIENT), if we ever upgrade the underlying implementation to allow that. But I remain concerned about dealing with logic like "if (elevel < ERROR)", and I am unconvinced that there's a near-term use-case here that's compelling enough to justify finding all the places that do that. regards, tom lane -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers