Is the following description now outdated:
"ForeignPath represents a potential scan of a foreign table"
Considering that there now exists FdwRoutine.GetForeignJoinPaths() whose
product is nothing else but a ForeignPath, should it now say (patch attached):
"ForeignPath represents a potential scan of foreign table(s)"
Or something better.
diff --git a/src/include/nodes/relation.h b/src/include/nodes/relation.h
index e9dfb66..b11f29f 100644
@@ -1030,7 +1030,7 @@ typedef struct SubqueryScanPath
- * ForeignPath represents a potential scan of a foreign table
+ * ForeignPath represents a potential scan of foreign table(s)
* fdw_private stores FDW private data about the scan. While fdw_private is
* not actually touched by the core code during normal operations, it's
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: