On 06/05/16 07:44, Tom Lane wrote:
Stas Kelvich <s.kelv...@postgrespro.ru> writes:
On 04 May 2016, at 20:15, Tom Lane <t...@sss.pgh.pa.us> wrote:
Also, I'd supposed that we'd rename to tsvector_something, since
the same patch also introduced tsvector_to_array() and
array_to_tsvector().  What's the motivation for using ts_ as the
There is already several functions named ts_* (ts_rank, ts_headline, ts_rewrite)
and two named starting from tsvector_* (tsvector_update_trigger, 
Personally I’d prefer ts_ over tsvector_ since it is shorter, and still keeps 
Yeah, I see we're already a bit inconsistent here.  The problem with using
a ts_ prefix, to my mind, is that it offers no option for distinguishing
tsvector from tsquery, should you need to do that.  Maybe this isn't a
problem for functions that have tsvector as input.

                        regards, tom lane

use tsv_ and tsq_?


Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to