14.10.2016, 07:38, Peter Eisentraut kirjoitti:
On 10/12/16 11:22 AM, Tom Lane wrote:
The main problem we're trying to fix here is people thinking that
something with "log" in the name contains discardable data. Just
relocating the directory without renaming it won't improve that.
I think it would help if we moved it to something like
"internal/pg_xlog" and "internal/pg_clog". Keep the name but move it
out of sight.
We have a tool called pg_xlogdump in the standard installation. initdb
has an option --xlogdir, pg_basebackup has --xlog and others. Renaming
the xlog directory would make this all a bit confusing, unless we're
prepared to rename the programs and options as well.
pg_receivexlog should probably be renamed, seeing how we have
pg_recvlogical perhaps pg_recvwal would work?
The --xlog, -x, --xlog-method and -X flags for pg_basebackup are a bit
confusing as it is. Perhaps they can be kept around as deprecated
aliases for a new --wal stream/fetch switch: I don't think we need new
--wal and --wal-method switches.
pg_resetxlog should probably be called something different than just
plain pg_resetwal to make it obvious that running it will cause data loss.
pg_xlogdump is a developer tool, users shouldn't care; it's hard enough
to use as it is as it doesn't do anything useful when you try to point
it to a recycled wal file.
All in all, I think this is a good opportunity to clarify what the tools
are actually supposed to do and who should be running them. As an
author of a backup tool utilizing some of these tools & options I don't
think renaming commands and/or arguments is a big deal -- we have to
deal with a bunch of changes for every new major version anyway.
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: