On 1/17/17 5:03 PM, Robert Haas wrote: > Right. I think a lot of that stuff should also be changed. If we > weren't OK with breaking compatibility, why'd we change pg_xlog -> > pg_wal? If we're not willing to change other things to match, let's > revert that change and be done with it.
For the record, I don't like the name "xlog" either. It would be nice if we could have more consistent and intuitive naming. But I don't see any proposals to actually change all uses of "xlog" to "wal". What about program names, command line options, etc.? If the argument is, we changed one thing, we should change the rest, then let's see that. I think that argument itself is flawed, but if that's what we're going with, let's see the whole plan. Moreover, I see we still have the pg_clog directory. I thought that was supposed to be renamed as well, to avoid confusing it with a "log" directory. Surely, we should at least conclude that original chapter before going further. -- Peter Eisentraut http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers