I notice that the existing tsearch documentation that we've imported
fairly consistently refers to Snowball dictionaries with names like
"en_stem", "ru_stem", etc.  However, CVS HEAD is set up to create them
with names "english", "russian", etc.  As I've been absorbing more of
the docs I'm starting to wonder whether this is a good idea.  ISTM
that these names encourage a novice to think that the one dictionary
is all you could need for a given language; and there are enough
examples of more-complex setups in the docs to make it clear that
in fact Snowball is not the be-all and end-all of dictionaries.

I'm thinking that going back to the old naming convention (or something
like it --- maybe "english_stem", "russian_stem", etc) would be better.
It'd help to give the right impression, namely that these dictionaries
are a component of a solution but not necessarily all you need.


                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 7: You can help support the PostgreSQL project by donating at


Reply via email to