Joe Conway wrote:
> Tom Lane wrote:
> > One could make a good case that INDEX_MAX_KEYS should be exported along
> > with FUNC_MAX_ARGS, rather than letting people write client code that
> > assumes they are the same.
> > 
> > I was intending to propose that we also export the following as
> > read-only variables:
> >     * NAMEDATALEN
> >     * BLCKSZ
> >     * integer-vs-float datetime flag
> 
> OK, the attached includes the above -- result looks like:
> 
> regression=# select * from pg_settings where category like 'Compile%';
> -[ RECORD 1 ]----------------------------------------------
> name       | block_size

OK.  Should that be page_size?  Not sure but block size sounds more like
a hardware setting.  I know we call it BLCKSZ in our code but page size
seems more appropriate.  Not sure.

> name       | func_max_args
> name       | index_max_keys

Should that be max_func_args and max_index_args?  Seems more natural.
Should we spell out function?  Probably.  We already have
check_*function*_bodies.

> name       | integer_datetimes
> short_desc | Datetimes are integer based

This one has me confused.  "Datetimes are integer based" is a statement,
as is the variable name.  Should it be "integer_datetime_storage" or
something else?

> name       | name_data_len

Is "name" a good description, or is "identifier" better, identifier_length?

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [EMAIL PROTECTED]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Reply via email to