Joshua D. Drake wrote:
Michael Glaesemann wrote:


On Jul 6, 2007, at 5:53 , Dave Page wrote:

On Fri, July 6, 2007 8:51 am, Peter Eisentraut wrote:
Am Mittwoch, 4. Juli 2007 17:04 schrieb Zdenek Kotala:
I attach complete patch which renames following binaries

createdb createlang createuser dropdb droplang dropuser clusterdb
vacuumdb reindexdb

I just want to say I dislike this idea.

This is almost as bad as Magnus agreeing with JD (!), but I agree with
Peter :-). After years of typing the current names, changing them does
seem somewhat annoying. Worse yet, pg_* is just awkward to type.

While the change might be awkward, the names of these binaries really should be namespaced in some way. The current just too generic to be throwing into a bin/ directory in my opinion.

Of course I realize that I voted for the idea in the first place. I voted for it for consistency more than anything but as I think about it, it really is clunky and doesn't serve any real purpose.


There is group of people who has different opinion. The main reasons for this patch are 1) names could collide with system tools 2) it is confusing for lot of users - typically for newbies and me :-) 3) it is not consistent with naming convention.

I started to use postgres since version 6.5 and these names of script utilities are still confusing for me.

By the way my original idea was create new command "pg_cmd", which integrates all in one include missing commands(e.g. createtablespace).


                Zdenek

---------------------------(end of broadcast)---------------------------
TIP 5: don't forget to increase your free space map settings

Reply via email to