Damien Pollet started to have a look at the makefile and this is on my todo to try.


Le 15/9/16 à 00:13, Johan Fabry a écrit :
Hi Doru,

it looks like there’s a problem with copySupport.mk, I had the same problem 
with the Spec booklet. The file is using Linux only syntax for the cp command. 
This was fixed for the Spec booklet after I raised an issue there, but it seems 
the fix was not propagated everywhere it needs to be. Have a look at 
 and try to update your copySupport, it may fix your problem.

Does this mail seem too brief? Sorry for that, I don’t mean to be rude! Please 
see http://emailcharter.org .

Johan Fabry   -   http://pleiad.cl/~jfabry
PLEIAD and RyCh labs  -  Computer Science Department (DCC)  -  University of 

On Sep 14, 2016, at 18:40, Tudor Girba <tu...@tudorgirba.com> wrote:


Ok, I found this document:

And now I tried this:

        wget --no-check-certificate 
        chmod +x download.sh
        ./pillar archetype book

and I got the book template. But, I do not know how to compile the book. I tried


        make book

but I get:

mkdir -p ./book-result
find . -type d -path ./book-result -prune -o -wholename "*/figures" -exec cp {} 
--parents -r ./book-result \;
cp: ./Chapters/Chapter1/figures is a directory (not copied).
cp: --parents: No such file or directory
cp: -r: No such file or directory
cp: ./figures is a directory (not copied).
cp: --parents: No such file or directory
cp: -r: No such file or directory
cp: ./support/figures is a directory (not copied).
cp: --parents: No such file or directory
cp: -r: No such file or directory
cp -r support/ ./book-result
cp .latexmkrc ./book-result
cp: .latexmkrc: No such file or directory
make: *** [copySupport] Error 1

I must be doing something wrong, but I do not know what. I am on a Mac 10.11 
and I am using bash. Could someone point me in the right direction?


On Sep 14, 2016, at 10:49 PM, Tudor Girba <tu...@tudorgirba.com> wrote:


Where can I find the new template system for Pillar?


On Jul 22, 2016, at 3:41 PM, Thibault ARLOING <thibault.arlo...@hotmail.fr> 


I'm happy to announce the latest release of Pillar.
This release has been possible because of the hard work of Damien Cassou, Cyril 
Ferlicot, Yann Dubois, Thibault Arloing and Lukas Komarek.
What did it bring and what are the largest changes ?

        • Huge cleaning of code and Dependencies
        • Many bug fixes
        • Huge refactoring of internal parts
                • Extract phase management into an external project 
                • Transformers and Phases are all Pipes
Remove Compilation cycle
        • Remove template handling from Pillar
        • Remove generation of pillarpostExport.sh
        • Pillar now exports files to JSON format
        • Command for pillar archetypes "./pillar archetype book", book can be 
replaced by other archetype names (see Pillar documentation)
        • Possibility to load an archetype with a Makefile to compile pillar 
        • Check phase to check syntax
        • EPub exporter for e-books (use pillar archetypes for this)
        • Semantic links to Youtube and Wikipedia
        • Citations for LaTeX
        • Structures (see Pillar documentation)
        • Footnotes for HTML, Markdown, LaTeX and AsciiDoc
        • Improvement of parsing configuration failure message
Major changes
        • Metadata field in configuration to separate data from configuration 
        • Support files in configuration does no longer exists
        • "disableTransformers" property is now named "disabledPhases"
        • AsciiDoc file extension is now ".asciidoc"
        • Pillar now manages one input file, not a collection of input files 
                • Parameter inputFiles is now replaced by inputFile
The documentation of Pillar will be update as soon as possible to fit those 



"Sometimes the best solution is not the best solution."


"It's not how it is, it is how we see it."

Reply via email to