heh… the format I propose is like this: 

methodDeclaration [
  methodbody
]

I think that keeps good readability and I can parse it easily. 

> On 10 Sep 2017, at 18:23, Stephane Ducasse <stepharo.s...@gmail.com> wrote:
> 
> Hi esteban
> for me having space around [ ] improves readibility.
> I preferred
> 
> methodDeclaration
>   [
>   methodbody
>   ]
> 
> over
> 
> methodDeclaration
>   [ methodbody ]
> 
> Especially in case of method body is blockish like while true/exception.
> 
> But this is ok if people prefer
> 
> methodDeclaration
>   [ methodbody ]
> 
> 
> Now I do not like
> 
> methodDeclaration [
>   methodbody ]
> 
> Stef
> 
> On Sun, Sep 10, 2017 at 10:25 AM, Esteban Lorenzano <esteba...@gmail.com> 
> wrote:
>> 
>> On 9 Sep 2017, at 19:35, Eliot Miranda <eliot.mira...@gmail.com> wrote:
>> 
>> 
>> Point class >> x: anInt1 y: anInt2
>>  [
>>    ^ self new setX: anInt1 Y: anInt2]
>> 
>> because trailing white space will only accumulate, something I see in Pharo
>> and Squeak code.
>> 
>> Alternatively have the output add white space if required and the input
>> remove any and all trailing white space.
>> 
>> 
>> in fact, I’m working to remove the extra trailings this format can add. The
>> idea is that parsed text == original text. Then, originally my format was
>> 
>> methodDeclaration [
>> methodBody
>> ]
>> 
>> but now I’m digging also into
>> 
>> methodDeclaration [
>> methodBody ]
>> 
>> (always keeping the identity of sources idea)
>> 
>> cheers!
>> Esteban
>> 
> 


Reply via email to