First of all i have searched for this trouble on the news(
groups.google.com); on Oracle docson  phpbuilder site; in php general, php
db mailing list's .

The problem:

Background info:
PHP version: 4.1.2
OS: Linux Suse 7
OCI version: 8
Database version: 7.x
Database OS: HP/UX

I need to do a select for a field that is varchar2.
The field contains strings that have some char's like (  in html á,
 in html ã).

The problem is that instead of these nice char's a get a ?.

This seams to me a PHP/OCI probleam, because if a use SQL Plus 8 ( on a
Windows machine )or other cliente, i get every thing ok.

What a have tried til now:

Changing the NLS_LANG env var( with PutEnv in Apache )...no luck.

The result for: select * from NLS_SESSION_PARAMETRS is the same on the
Windows client and on PHP( i thought that OCI layer was using some defaults
of it's own ).

The database was created with the right NLS_PARAMETER's ( if it were not, i
couldnt get these char's in SQLPLUS ).

One more thing....i very new to Oracle....but i have worked with other DBMS
like MSSQL Server, MySQL, Postgres.

Does any one has seen this before?
Is this a known probleam?
Does any one have any tip to solve this probleam?

Miguel Carvalho

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to