ID: 12064
Updated by: dbeu
Reported By: [EMAIL PROTECTED]
Old Status: Feedback
Status: Closed
Bug Type: GD related
Operating System: Windows 2000 SP1
PHP Version: 4.0.6
New Comment:

already fixed in cvs.

Previous Comments:
------------------------------------------------------------------------

[2001-07-22 19:22:09] [EMAIL PROTECTED]

That would take a good look at the source code to see how PHP is passing arguments to 
the GD library.

------------------------------------------------------------------------

[2001-07-22 19:20:16] [EMAIL PROTECTED]

Fixing "null" status.

So, is this a GD Bug, or a PHP bug?

------------------------------------------------------------------------

[2001-07-12 17:34:06] [EMAIL PROTECTED]

Ok, I checked out filemon.
Here's what's happening:
GD first tries to open files inside the Apache root (not the web root; for instance, 
on my box, C:\Program Files\Apache. So, if I've specified "C:\\path\\to\\font.ttf" in 
my path, I end up with:
C:\Program Files\Apache\C\C:\path\to\font.ttf.ttf

Next, it tries the current directory. However, it seems to be unable to process 
Windows drive letters, and so defaults to drive C: (my webroot's on D:, which is a 
problem), so I get
C:\path\to\script\C:\path\to\font.ttf.ttf

You get the idea. I made a directory structure on C: mimicing that of my D: webroot, 
but only containing the fonts; it worked fine (although the antialiasing was horrific, 
but that's a GD/FT2 issue).


------------------------------------------------------------------------

[2001-07-12 17:18:32] [EMAIL PROTECTED]

Pretty sure, but it doesn't work the other way around either.

------------------------------------------------------------------------

[2001-07-12 16:08:57] [EMAIL PROTECTED]

Are you sure that GD understands d:/path/to/font.ttf as a path?
Should it be d:\\path\\to\\font.ttf ?

--Wez.

------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/?id=12064


Edit this bug report at http://bugs.php.net/?id=12064&edit=1


-- 
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to