I personally agree with the idea of targeting 7.0 and up, Larry made a good 
case for it.

Release two versions is confusing. A PSR needs to be a simple and clear 
message: one solution, one version, one recommended way to do it.

It's also (IMO) a good thing that the FIG pushes PHP 7 forward.

Matthieu

Le samedi 5 août 2017 12:02:28 UTC+2, Niklas Keller a écrit :
>
> Something like that is pretty stupid. It prevents having an implementation 
>>> that's compatible with both, 5.6 and 7. And two versions of a package can't 
>>> be installed side-by-side with Composer. New major versions of PSRs should 
>>> definitely use new package names for that reason.
>>>
>>> Regards, Niklas 
>>>
>>
>> This has been brought up a number of times already, and disregarding it 
>> as "stupid" will not drive to a definitive solution.
>>
>> At PHPDay unconference, participants in the discussion deemed this as 
>> generally not much of an issue, mostly because you already have to comply 
>> to this constraint anyway: you can't install packages having incompatible 
>> dependency graphs, so why bother trying to circumvent this limitation for 
>> PSRs only?
>>
>
> It doesn't only affect PSRs, but it's probably worth doing it for them, 
> because they're interfaces used by many packages and conflicts are thus 
> very bad.
>  
>
>> While I understand and agree with the principle, in practice the chance 
>> of having dependency issues due to migrations between major versions is 
>> very high anyway.
>>
>
> So why increase the risk with PSRs if it can be avoided by using different 
> package names for future versions of PSRs? It's perfectly fine to have two 
> versions of an interface in different namespaces.
>  
>
>> That said, if we want to release entirely different PSRs for updated 
>> versions (which would be arguably a cleaner solution), I think we need to 
>> streamline the process and make it easier, because at the moment it's so 
>> much of a PITA that nobody wants to do it.
>>
>
> It's something the FIG needs to solve then.
>
> Regards, Niklas 
>

-- 
You received this message because you are subscribed to the Google Groups "PHP 
Framework Interoperability Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to php-fig+unsubscr...@googlegroups.com.
To post to this group, send email to php-fig@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/php-fig/1cca0954-28c2-4ac3-93ff-009807c4720c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to