Cal Evans wrote:

>Have you tried shaving the article off a couple of chrs before the last one
>and seeing if the insert works? Also, what is the size limit on a MySQL TEXT
>May give a hint.
I tried shaving off the article to the size that it truncated it to on 
its own, and the add worked fine.  It seems to be a concrete limit of 
about 8-9K.

>-----Original Message-----
>From: Chris Snyder [mailto:[EMAIL PROTECTED]]
>Sent: Sunday, March 31, 2002 3:43 PM
>Subject: [PHP] Issues with long SQL inserts
>Server is running PHP 4.1.2, APC 1.1.0pl1, MySQL 3.23.47, Apache 1.3.23
>on a built-from-scratch Linux system with kernel 2.4.17, glibc 2.2.5,
>and gcc 3.0.4.
>I'm using a fairly simple script to take input from a form, and add it
>to a database.  The database has the following structure:
>ID - mediumint(8), primary key, auto_increment
>Added - date
>Modified - timestamp(8)
>Title - varchar(60)
>Text - text
>What's happening is whenever I try to add an article that has text with
>a size of over around 9 KB, the browser never finishes loading, and the
>article doesn't appear in the list.  When I hit the stop button on the
>browser, the article will then appear in the article list, but
>incomplete - it is always cut off at the same spot.
>This sounds like some kind of buffer issue, but I've looked through all
>of the applicable settings that I could find in both my PHP and MySQL
>configuration files, and have found nothing.  Any ideas?  Thanks in
>advance.  To see the source code for this script, go to
> .  Thanks in advance for any help!
>PHP General Mailing List (
>To unsubscribe, visit:

PHP General Mailing List (
To unsubscribe, visit:

Reply via email to