thank you very much,and i already reinstall my os system,and now is
win2003,and it's is fine,
but another question is :when i use the php sca to reference the wsdl
which generated by apache tuscany sca,
the php can not get the result,even the sample is helloworld,why?

and this is the wsdl which generated by apache tuscany sca:

 use java create a wsdl which published in Tomcat 6,the wsdl is:
 <?xml version="1.0" encoding="UTF-8" ?>
- <wsdl:definitions name="IUserserviceService"
targetNamespace="http://
service.tuscanytest.com/" xmlns:tns="http://service.tuscanytest.com/";
xmlns:SOAP="http://schemas.xmlsoap.org/wsdl/soap/";
xmlns:SOAP11="http://schemas.xmlsoap.org/wsdl/soap/";
xmlns:xs="http://
www.w3.org/2001/XMLSchema" xmlns:wsdl="http://schemas.xmlsoap.org/
wsdl/">
- <wsdl:types>
- <xs:schema version="1.0" xmlns:xs="http://www.w3.org/2001/
XMLSchema">
- <xs:complexType name="user">
- <xs:sequence>
  <xs:element minOccurs="0" name="address" type="address" />
  <xs:element minOccurs="0" name="id" type="xs:string" />
  <xs:element minOccurs="0" name="name" type="xs:string" />
  <xs:element minOccurs="0" name="password" type="xs:string" />
  </xs:sequence>
  </xs:complexType>
- <xs:complexType name="address">
- <xs:sequence>
  <xs:element minOccurs="0" name="street" type="xs:string" />
  </xs:sequence>
  </xs:complexType>
  </xs:schema>
- <xs:schema attributeFormDefault="qualified"
elementFormDefault="unqualified" targetNamespace="http://
service.tuscanytest.com/" xmlns:xs="http://www.w3.org/2001/
XMLSchema">
- <xs:element name="getAllResponse">
- <xs:complexType>
- <xs:sequence>
  <xs:element minOccurs="0" name="return" nillable="true"
type="xs:anyType" />
  </xs:sequence>
  </xs:complexType>
  </xs:element>
- <xs:element name="getAll">
  <xs:complexType />
  </xs:element>
  </xs:schema>
  </wsdl:types>
- <wsdl:message name="getAllResponse">
  <wsdl:part name="getAllResponse" element="tns:getAllResponse" />
  </wsdl:message>
- <wsdl:message name="getAll">
  <wsdl:part name="getAll" element="tns:getAll" />
  </wsdl:message>
- <wsdl:portType name="IUserservice">
- <wsdl:operation name="getAll">
  <wsdl:input message="tns:getAll" />
  <wsdl:output message="tns:getAllResponse" />
  </wsdl:operation>
  </wsdl:portType>
- <wsdl:binding name="IUserserviceBinding" type="tns:IUserservice">
  <SOAP:binding style="document" transport="http://
schemas.xmlsoap.org/
soap/http" />
- <wsdl:operation name="getAll">
  <SOAP:operation />
- <wsdl:input>
  <SOAP:body use="literal" />
  </wsdl:input>
- <wsdl:output>
  <SOAP:body use="literal" />
  </wsdl:output>
  </wsdl:operation>
  </wsdl:binding>
- <wsdl:service name="IUserserviceService">
- <wsdl:port name="IUserservicePort"
binding="tns:IUserserviceBinding">
  <SOAP:address location="http://172.16.18.15:8085/tuscanytest/
UserService" />
  </wsdl:port>
  </wsdl:service>
  </wsdl:definitions>

when i use php to call it,i use the code :
include 'SCA/SCA.php';
$greeting_service  = SCA::getService('http://172.16.18.15:8085/
tuscanytest/UserService?wsdl');
while ($arr=$greeting_service->getAll())
 {


 echo($arr["name"]);
 }







--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"phpsoa" group.
To post to this group, send email to phpsoa@googlegroups.com
To unsubscribe from this group, send email to 
phpsoa+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.co.uk/group/phpsoa?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to