Hi Alex!
Thanks, all right with idForm.
Now I see another strange behaviour. My steps (CentOS 6.2 x64):
yum update
yum install gcc gcc-c++ glibc-devel.i686 openssl-devel file
cd /opt
wget "http://software-lab.de/picoLisp.tgz"; && tar xzf picoLisp.tgz
wget "http://software-lab.de/wiki.tgz"; && tar -C picoLisp -xzf wiki.tgz
wget "http://software-lab.de/socialshareprivacy.tgz"; && \
tar -C picoLisp -xzf socialshareprivacy.tgz
mkdir -p /usr/share/javascript/jquery && wget -O \
/usr/share/javascript/jquery/jquery.js \
cd /opt/picoLisp/src && make picolisp tools gate
cd /opt/picoLisp/src64 && make picolisp

cd /opt/picoLisp && ./pil wiki/main.l -main -go +

Then I load http://wiki.mysite:5000 in Firefox, log in (admin:admin), navigate to "Articles & Essays" in the left menu. I see "New document 'Articles', This document doesn't exist yet". Seems ok. I press "Create document", fill the body and summary, save the document and now I see that created page and "Edit" link on the top of it. Ok. But when I try to navigate to "Articles & Essays", I see "This document doesn't exist yet" again.
The same happens with other links in the left menu.
What I'm doing wrong?

Best regards,

Hi all,

idForm -- Undefined

While this was not really a bug in the Wiki, there _was_ another bug.

José Romero triggered it unintentionally yesterday, and I could easily
reproduce it. It crashed the Wiki when you tried to delete a Document
(via the "Delete" button), because of a bug in the recently-introduced
text indexing.

I fixed it, and uploaded a new "wiki.tgz".

@Mansur: In case you downloaded your "wiki.tgz" earlier than 13:02 UTC
today, please fetch it once more.

- Alex

UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe

Reply via email to