On Sun, Jan 09, 2011 at 04:26:11PM -0800, Walter Landry wrote:
> Greetings,
> 
> I was recently bitten by this bug again.  HDF5 has had the new API for
> almost 3 years.  This is getting a bit ridiculous.  It is time for
> Debian to use the new API.  From
> 
>   http://www.hdfgroup.org/HDF5/doc/RM/APICompatMacros.html
> 
>   For new code development, The HDF Group recommends use of the
>   compatibility macro mapped to the latest version of the function.
> 
> Debian is making it impossible to use this compatibility macro.  If
> you download HDF5 from the net and build software against it using the
> recommended API, it will not then build against the Debian version.
> 
> In addition, it seems that there is an easy workaround for people who
> want to use the old API, but there is no easy workaround for people
> using the new API.
> 
> So pretty please, with sugar on top, change the default API.
> 

This is something which can be considered for squeeze+1: at that
point hopefully none will use still the 1.6 interface without
pre-checking or using useful wrappers.

-- 
Francesco P. Lovergine



_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-grass-devel

Reply via email to