Package: qgis
Version: 2.8.1+dfsg1-1+b1
Severity: important

--- Please enter the report below this line. ---

Any attempt at connecting to spatialite database produces segmentation fault. 

Downgrading to qgis 2.4.0 does NOT help, but it used to work. On the other 
hand, spatialite's own tools seem to work, so I am not sure whether this is 
qgis or spatialite bug.

Backtrace is:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff65c2b700 (LWP 3818)]
0x00007ffff0186ff4 in spatialite_init (verbose=0) at spatialite_init.c:114
114     spatialite_init.c: No such file or directory.

(gdb) bt
#0  0x00007ffff0186ff4 in spatialite_init (verbose=0) at spatialite_init.c:114
#1  0x00007fff77ea5171 in QgsSpatiaLiteConnection::openSpatiaLiteDb(QString) () 
from /usr/lib/qgis/plugins/libspatialiteprovider.so
#2  0x00007fff77ea7140 in QgsSpatiaLiteConnection::fetchTables(bool) () from 
/usr/lib/qgis/plugins/libspatialiteprovider.so
#3  0x00007fff77ea1f4e in QgsSLConnectionItem::createChildren() () from 
/usr/lib/qgis/plugins/libspatialiteprovider.so
#4  0x00007ffff402d8c7 in QgsDataItem::runCreateChildren(QgsDataItem*) () from 
/usr/lib/libqgis_core.so.2.8.1
#5  0x00007ffff40347d1 in QtConcurrent::RunFunctionTask<QVector<QgsDataItem*> 
>::run() () from /usr/lib/libqgis_core.so.2.8.1
#6  0x00007ffff2b23b80 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007ffff2b3080f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fffef3000a4 in start_thread (arg=0x7fff65c2b700) at 
pthread_create.c:309
#9  0x00007fffef5fb04d in clone () at 
../sysdeps/unix/sysv/linux/x86_64/clone.S:111

(gdb) info frame
Stack level 0, frame at 0x7fff65c29f30:
 rip = 0x7ffff0186ff4 in spatialite_init (spatialite_init.c:114); saved rip = 
0x7fff77ea5171
 called by frame at 0x7fff65c29f70
 source language c.
 Arglist at 0x7fff65c29f18, args: verbose=0
 Locals at 0x7fff65c29f18, Previous frame's sp is 0x7fff65c29f30
 Saved registers:
  rbx at 0x7fff65c29f20, rip at 0x7fff65c29f28

(gdb) info locals
No locals.

This happens immediately at any attempt to connect to spatialite database, 
rendering the spatialite backend unusable.

I installed spatialite debug symbols for the above backtrace, but it does not 
seem to show much extra data. I can't find debug data for the other binaries.

--- System information. ---
Architecture: amd64
Kernel:       Linux 3.16.0-4-amd64

Debian Release: stretch/sid
  990 testing         http.debian.net 
  500 unstable        http.debian.net 
  500 trusty          ppa.launchpad.net 
  500 testing-proposed-updates http.debian.net 
  500 stable-updates  ftp.cz.debian.org 
  500 stable          security.debian.org 
  500 stable          ftp.cz.debian.org 
    1 experimental    http.debian.net 

--- Package information. ---
Depends                                      (Version) | Installed
======================================================-+-
======================
libc6                                        (>= 2.14) | 
libexpat1                                   (>= 2.0.1) | 
libgcc1                                   (>= 1:4.1.1) | 
libgdal1h                                   (>= 1.8.0) | 
libgeos-c1                                  (>= 3.4.2) | 
libgsl0ldbl                                   (>= 1.9) | 
libpq5                                                 | 
libproj0                                    (>= 4.8.0) | 
libqgis-analysis2.4.0                       (>= 2.0.1) | 
libqgis-core2.4.0                           (>= 2.4.0) | 
libqgis-gui2.4.0                            (>= 2.4.0) | 
libqgis-networkanalysis2.4.0                (>= 2.0.1) | 
libqt4-network                            (>= 4:4.6.1) | 
libqt4-sql                                (>= 4:4.5.3) | 
libqt4-svg                                (>= 4:4.5.3) | 
libqt4-xml                                (>= 4:4.5.3) | 
libqtcore4                                (>= 4:4.8.0) | 
libqtgui4                                 (>= 4:4.8.0) | 
libqtwebkit4                     (>= 2.1.0~2011week13) | 
libqwt6                                                | 
libspatialindex3                            (>= 1.8.1) | 
libspatialite5                              (>= 2.4.0) | 
libsqlite3-0                                (>= 3.5.9) | 
libstdc++6                                    (>= 4.9) | 
qgis-providers                        (= 2.4.0-1~exp1) | 
qgis-common                           (= 2.4.0-1~exp1) | 


Recommends             (Version) | Installed
================================-+-===========
qgis-plugin-grass                | 2.8.1+dfsg1-1+b1
qgis-plugin-globe                | 2.8.1+dfsg1-1+b1
python-qgis                      | 2.8.1+dfsg1-1+b1


Suggests      (Version) | Installed
=======================-+-===========
gpsbabel                | 1.5.0-3




-- 
 - Jan Hudec <b...@ucw.cz>

_______________________________________________
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Reply via email to