I was able to build it on armel with the attached patch. I only tested
in a chroot under QEMU, so perhaps it won't work on real hardware.
However, if you could include this patch, or something like it, with
the next upload I'd be interested to see what happens.

diff -ru nodejs-4.0.0~dfsg.orig/configure nodejs-4.0.0~dfsg/configure
--- nodejs-4.0.0~dfsg.orig/configure
+++ nodejs-4.0.0~dfsg/configure
@@ -604,7 +604,7 @@
     o['variables']['arm_fpu'] = 'vfpv3'
     o['variables']['arm_version'] = '7'
   else:
-    o['variables']['arm_fpu'] = 'vfpv2'
+    o['variables']['arm_fpu'] = 'vfp'
     o['variables']['arm_version'] = '6' if is_arch_armv6() else 'default'
 
   o['variables']['arm_thumb'] = 0      # -marm
diff -ru nodejs-4.0.0~dfsg.orig/debian/rules nodejs-4.0.0~dfsg/debian/rules
--- nodejs-4.0.0~dfsg.orig/debian/rules
+++ nodejs-4.0.0~dfsg/debian/rules
@@ -56,6 +56,13 @@
 DEB_CONFIGURE_EXTRA_FLAGS += --dest-cpu=$(destCpu)
 endif
 
+ifeq (armel, $(DEB_HOST_ARCH))
+CC = gcc -march=armv6
+CXX = g++ -march=armv6
+export CC
+export CXX
+endif
+
 DEB_DESTDIR = $(CURDIR)/debian/tmp
 DEB_MAKE_CLEAN_TARGET = clean
 
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to