On Tue, Sep 15, 2015 at 3:34 AM, Jérémy Lal <kapo...@melix.org> wrote:
>
>
> 2015-09-15 10:09 GMT+02:00 Edmund Grimley Evans
> <edmund.grimley.ev...@gmail.com>:
>>
>> I was able to build it on armel with the attached patch. I only tested
>> in a chroot under QEMU, so perhaps it won't work on real hardware.
>> However, if you could include this patch, or something like it, with
>> the next upload I'd be interested to see what happens.

Sorry guys:

ifeq (armel, $(DEB_HOST_ARCH))
CC = gcc -march=armv6
CXX = g++ -march=armv6
export CC
export CXX
endif

That's actually not going to work for "armel" hardware...  "armel" is
currently built as "armv4t", so "-march=armv6" is going to cause
invalid instruction faults on devices running armel..

https://en.wikipedia.org/wiki/List_of_ARM_microarchitectures

While there is some talk to possibly bump it to "armv5" for stretch:

https://lists.debian.org/debian-arm/2015/09/msg00038.html

Regards,

-- 
Robert Nelson
https://rcn-ee.com/

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to