Your message dated Fri, 23 Dec 2016 15:48:38 +0000
with message-id <e1cks5g-0004xr...@fasolo.debian.org>
and subject line Bug#815567: fixed in amarok 2.8.0-7
has caused the Debian Bug report #815567,
regarding Amarok should depend on virtual-mysql-server-core to support MariaDB
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
815567: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815567
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: amarok
Severity: grave

On line 
http://anonscm.debian.org/cgit/pkg-kde/kde-extras/amarok.git/tree/debian/control#n20
Amarok defines as build dependency:

Build-Depends-Indep: mysql-server-core-5.6 | mysql-server-core

This should be changed to:

Build-Depends-Indep: mysql-server-core-5.6 | virtual-mysql-server-core

Or if you prefer MariaDB:

Build-Depends-Indep: mariadb-server-core-10.0 | virtual-mysql-server-core

In https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=793977 Martin
Steigerwald reports he used Akonadi with MariaDB.

It is up to the package maintainer to choose what is the primary
option, but the alternative should be the virtual-* package that is
provided by all variants. In fact you MUST have this
virtual-mysql-server-core to also support any future versions of the
databases, e.g. mysql-server-core-5.7.

More information at: https://wiki.debian.org/Teams/MySQL/virtual-mysql-server

--- End Message ---
--- Begin Message ---
Source: amarok
Source-Version: 2.8.0-7

We believe that the bug you reported is fixed in the latest version of
amarok, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 815...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Pino Toscano <p...@debian.org> (supplier of updated amarok package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Fri, 23 Dec 2016 16:33:17 +0100
Source: amarok
Binary: amarok amarok-common amarok-doc amarok-utils
Architecture: source
Version: 2.8.0-7
Distribution: unstable
Urgency: medium
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Changed-By: Pino Toscano <p...@debian.org>
Description:
 amarok     - easy to use media player based on the KDE Platform
 amarok-common - architecture independent files for Amarok
 amarok-doc - Amarok documentation (Handbook)
 amarok-utils - utilities for Amarok media player
Closes: 655362 815567 845798
Changes:
 amarok (2.8.0-7) unstable; urgency=medium
 .
   * Team upload.
   * Switch to the default MySQL implementation in Debian:
     - replace the libmysqld-pic build dependency with libmariadbd-dev; while
       it represents the current default MySQL version, in reality something
       like default-mysqld-dev would be needed (Closes: #845798)
     - replace the mysql-server-core-5.6 build dependency alternative with
       default-mysql-server-core (Closes: #815567)
   * Enable the gpodder.net support, now that libmygpo-qt is in Debian:
     (Closes: #655362)
     - add the libmygpo-qt-dev >= 1.0.9-2~ build dependency, with the version
       required because of #838229
     - update install files
   * Drop -DCMAKE_USE_RELATIVE_PATHS=ON from the CMake flags: it is no more
     supported in recent versions.
   * Update lintian overrides.
Checksums-Sha1:
 6b561aaa6f89103a91a4477cc122655ce4b57029 2738 amarok_2.8.0-7.dsc
 e2b550f260882f37e2e22f8c7bb5d819eee22375 45156 amarok_2.8.0-7.debian.tar.xz
Checksums-Sha256:
 20ddba910d05a8dd2543163056e29e415ee8067a82997904fce4463b45b19b5f 2738 
amarok_2.8.0-7.dsc
 9ac0607be5ecce00838990e58077e813c3104f45d256fe71e0dc69975fbbd8f2 45156 
amarok_2.8.0-7.debian.tar.xz
Files:
 eb357f82da319de4fe73e990242c43c6 2738 sound optional amarok_2.8.0-7.dsc
 e201276bdebfee4960dce01e4699ce09 45156 sound optional 
amarok_2.8.0-7.debian.tar.xz

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEXyqfuC+mweEHcAcHLRkciEOxP00FAlhdQ/4ACgkQLRkciEOx
P03nuQ//V/E4RzkeFo9+EvNuiwTTosgAW/uLMpbw2VeGBz6Tmp6QwvVrg4FqqROd
3xdhoeSarSg7bzmVGKmaFnZ3H5L+Y5BtZm920ppcXfyzqJ0xFCjHzGM0YXsZwOyQ
a3QoB91VU47IpsCv85m9gvZ5kFtmhkjgzM8hstB3I/qu2wu8yitYQyQpXmE4aUYk
pOXg0Bxrb+UaiEfovlV3KW4CYdfvdWGZC1ss5FK5TFFXsEhZkSCk+i9qSM7yWKhE
1NY9El3lA8PqD3qZ0WiYA1hHA7n5W7Gp9YgZ7vKfVLDf7hGuMQ5hOU9nSyBJ2NGG
aCJdEd9QuEIEkxw4jGvwMeYzqtqd6d1XZEhriHvOMF3kxYiAZOlqRVjrqPiUnQpb
GeMM1NRnZOLBRrvoHdbCDD5hnvrfK0a3VhygPuBxNkptQuAA7QDg/nFdKuJV2Sao
OFujGLA59x8Rk87c+ePBgBlu3qFN4V6oM6EJ+XF+SDC23YcWau0HxF1fKKrna2hk
nXmgJbc7piAFEFG1m1/ba21x+1CoZ4zjgD7vFAUbYCSQ9V7qtV8XS2VgyFDJpj86
sfXqU/9pjuWqRLIyUHC3MXhfg5KOBvbesPK9TZVjVhnJQfln6lAnNSjJq8PJG12s
pOKqVgJ7e+gobG80zX2gbdRjk61Jj5LfLCN3bijZr4k/P/EbMv8=
=EMOS
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to