From 5dfe778395410ef263884f781b74dce4ee4b3b45 Mon Sep 17 00:00:00 2001
From: Jeremy Bicha <jbi...@debian.org>
Date: Wed, 6 Dec 2017 19:36:26 -0500
Subject: [PATCH] Don't depend on libgtk2.0-0

so that themes can provide GTK+ 2 support
without requiring that GTK+ 2 be installed

Closes: #883737
---
 debian/rules | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/debian/rules b/debian/rules
index d0f71ac..96c59e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,4 +16,7 @@ override_dh_auto_configure:
 override_dh_makeshlibs:
 	dh_makeshlibs -X/usr/lib/$(DEB_HOST_MULTIARCH)/gtk-2.0
 
+override_dh_shlibdeps:
+	dh_shlibdeps -- -xlibgtk2.0-0
+
 .PHONY: override_dh_makeshlibs override_dh_auto_configure
-- 
2.14.1

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to