pgkos added a comment.
I have returned to the previous version, as the version which used
units.smallSpacing looked awful.
Yes, it uses magic constant 0.85, but it really looks much better. I have
patched the digital clock height too, so it perfectly matches the height of the
I think that this constant should be placed inside the Units class. More, I
also think this constant should be configurable by the user (for example, in
the panel settings -> more settings...).
This code has the benefit that it **does not change the appearance at the
default panel height at all** compared to the version without this patch. I
have tested this on both small HD screens and 4K HiDPI screens (with screen
scaling factor == 2.0), using KDE Neon git unstable live USB stick.
R120 Plasma Workspace
To: pgkos, #plasma_workspaces, davidedmundson
Cc: ngraham, davidedmundson, plasma-devel, ZrenBot, progwolff, lesliezhai,
ali-mohamed, jensreuterberg, abetts, sebas, apol, mart