On Mar 11, 2008, at 10:17 PM, Hazen Babcock wrote:
> I'm not seeing this on OS-X, but I am seeing it on my linux box so
> perhaps something changed between versions of the cairo library?
> PPC/64, pango 1.15.5, cairo 1.2.6. Ok.
> Intel/32, pango 1.16.5, cairo 1.4.10. Not Ok.

The problem seems to start in the proc_str() function at:
layout = pango_cairo_create_layout(aStream->cairoContext);
though it makes through several more lines of code before going down  
for good.

Curiously I found that if I ran my test program in the directory that  
I had make install plplot from then I didn't see the problem. I have  
the following the layout:
/home/hbabcock/C/plplot_test/test1 - the test program.
/home/hbabcock/OpenSource/plplot-working/plplot-CBS-1 - the directory  
I make installed plplot from.

This works:
debian ~/OpenSource/plplot-working/plplot-CBS-1 : pwd
debian ~/OpenSource/plplot-working/plplot-CBS-1 : /home/hbabcock/C/ 

This does not:
debian ~/C/plplot_test : pwd
debian ~/C/plplot_test : ./test1

And it doesn't seem to be the absolute path since it didn't work from  
a couple other directories that I tried.
Perhaps it is some sort of strange linking issue with pango / pango- 


This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
Plplot-devel mailing list

Reply via email to