> The problem seems to start in the proc_str() function at:
> layout = pango_cairo_create_layout(aStream->cairoContext);
> though it makes through several more lines of code before going down  
> for good.
> Curiously I found that if I ran my test program in the directory that  
> I had make install plplot from then I didn't see the problem. I have  
> the following the layout:
> /home/hbabcock/C/plplot_test/test1 - the test program.
> /home/hbabcock/OpenSource/plplot-working/plplot-CBS-1 - the directory  
> I make installed plplot from.
> This works:
> debian ~/OpenSource/plplot-working/plplot-CBS-1 : pwd
> /home/hbabcock/OpenSource/plplot-working/plplot-CBS-1
> debian ~/OpenSource/plplot-working/plplot-CBS-1 : /home/hbabcock/C/ 
> plplot_test/test1
> This does not:
> debian ~/C/plplot_test : pwd
> /home/hbabcock/C/plplot_test
> debian ~/C/plplot_test : ./test1
> And it doesn't seem to be the absolute path since it didn't work from  
> a couple other directories that I tried.
> Perhaps it is some sort of strange linking issue with pango / pango- 
> cairo?

There isn't any chance of there being multiple copies of either pango or
plplot on the system, does there?  If so there's always a chance that
different versions are being picked up by the dynamic linker.  I can't
imagine how that might come about (excepting the inclusion of relative paths
in LD_LIBRARY_PATH which isn't generally a good idea) but it's a thought. 
If something like this was happening I would expect it to be evident through
the use of ldd:

  cd /home/hbabcock/OpenSource/plplot-working/plplot-CBS-1
  ldd /home/hbabcock/C/plplot_test/test1

  cd /home/hbabcock/C/plplot_test
  ldd ./test1

It's a very strange problem.  Is anything revealed by running test1 through
strace in the two scenarios?


This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
Plplot-devel mailing list

Reply via email to