Hi,

I am trying to debug a weird issue I have with a printer (Kyocera p2135dn). When I convert the attached PDF to postscript using pdftops, the printer accepts and prints the file properly, but when I use pdftocairo, the printer rejects the file with the following error:


Error name:   /configurationerror
Offending Command: --setpagedevice--
Operand Stack:
-dict-

Even when removing _everything_ on the pdf, as the examples I have a attached, I still get the "Offending Command" error. I have tried examining the content of the files, but I have a hard time pinpointing what could be wrong in the pdftocairo-generated file.

I am attaching 3 additional files (A,B,C) that show attempts I made to modify the file (thought maybe the page size/bounding box was the issue) but all three have failed printing with the same error...

Anyone have ideas of what I should investigate?

Thanks,
Pierre-Luc

Attachment: Test-jma-Envelop-Blank.pdf
Description: Adobe PDF document

Attachment: Test-jma-Envelop-Blank-pdftocairo0.41-cairo1.14.6.ps
Description: PostScript document

Attachment: Test-jma-Envelop-Blank-pdftops0.41.ps
Description: PostScript document

Attachment: Test-jma-Envelop-Blank-pdftocairo0.41-cairo1.14.6-manually-fixedA.ps
Description: PostScript document

Attachment: Test-jma-Envelop-Blank-pdftocairo0.41-cairo1.14.6-manually-fixedB.ps
Description: PostScript document

Attachment: Test-jma-Envelop-Blank-pdftocairo0.41-cairo1.14.6-manually-fixedC.ps
Description: PostScript document

_______________________________________________
poppler mailing list
poppler@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/poppler

Reply via email to