Can you try it with the current pdftocairo 0.47.0? The source is at 
https://poppler.freedesktop.org/


Do any of the non-printing ps files get errors if you view them with 
ghostscript?


Test-jma-Envelop-Blank-pdftocairo0.41-cairo1.14.6-manually-fixedC.ps got a 
/dictstackunderflow in --end-- error for me, but that is because it has an 
extra 'end' in the trailer.


If you think that the problem is the setpagedevice call, you could comment the 
line '266 621 cairo_set_page_size' in the ps and try to print it.


setpagedevice is usually OK unless you are trying to make an EPS.


Regards, William


________________________________
From: poppler <poppler-boun...@lists.freedesktop.org> on behalf of Pierre-Luc 
Samuel <pierre-luc.sam...@ticketmaster.com>
Sent: Monday, September 19, 2016 9:21 AM
To: poppler@lists.freedesktop.org
Subject: [poppler] pdftocairo Offending Command error when printing

Hi,

I am trying to debug a weird issue I have with a printer (Kyocera
p2135dn).  When I convert the attached PDF to postscript using pdftops,
the printer accepts and prints the file properly, but when I use
pdftocairo, the printer rejects the file with the following error:

Error name:   /configurationerror
Offending Command: --setpagedevice--
Operand Stack:
-dict-

Even when removing _everything_ on the pdf, as the examples I have a
attached, I still get the "Offending Command" error.  I have tried
examining the content of the files, but I have a hard time pinpointing
what could be wrong in the pdftocairo-generated file.

I am attaching 3 additional files (A,B,C) that show attempts I made to
modify the file (thought maybe the page size/bounding box was the issue)
but all three have failed printing with the same error...

Anyone have ideas of what I should investigate?

Thanks,
Pierre-Luc
_______________________________________________
poppler mailing list
poppler@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/poppler

Reply via email to