If you look inside cairo_set_page_size, it sets

        /PageSize exch def
        /ImagingBBox null def
You could try changing the names one at a time to something that won't exist, 
like PageSizexxx to see if one or the other has a value that the printer 
doesn't like. Maybe the null ImagingBBox messes up the printer. A lot of ppd 
files have sequences like "<</PageSize[612 792]/ImagingBBox 
null>>setpagedevice", so a null ImagingBBox should be OK.

setpagedevice can give an error if the printer does not support the PageSize. 

Regards, William

From: Pierre-Luc Samuel <pierre-luc.sam...@ticketmaster.com>
Sent: Monday, September 19, 2016 4:51 PM
To: William Bader; poppler@lists.freedesktop.org
Subject: Re: [poppler] pdftocairo Offending Command error when printing

On 09/19/2016 12:54 PM, William Bader wrote:

Can you try it with the current pdftocairo 0.47.0? The source is at 

I did try with pdftocairo 0.47 + cairo 1.15.2, but the resulting file is 

Do any of the non-printing ps files get errors if you view them with 

No, ghostscript shows no errors...

Test-jma-Envelop-Blank-pdftocairo0.41-cairo1.14.6-manually-fixedC.ps got a 
/dictstackunderflow in --end-- error for me, but that is because it has an 
extra 'end' in the trailer.

Yeah, manually-fixedC is probably broken, that was a lame attempt at finding 
the issue.

If you think that the problem is the setpagedevice call, you could comment the 
line '266 621 cairo_set_page_size' in the ps and try to print it.

setpagedevice is usually OK unless you are trying to make an EPS.

When I was using an older version of poppler + libcairo, that section was not 
there at all, but not having it causes other issues (namely, the printer 
doesn't know the page size and sends it to a random paper tray).  I'm actually 
upgrading BECAUSE I want that section!

Regards, William

From: poppler 
 on behalf of Pierre-Luc Samuel 
Sent: Monday, September 19, 2016 9:21 AM
To: poppler@lists.freedesktop.org<mailto:poppler@lists.freedesktop.org>
Subject: [poppler] pdftocairo Offending Command error when printing


I am trying to debug a weird issue I have with a printer (Kyocera
p2135dn).  When I convert the attached PDF to postscript using pdftops,
the printer accepts and prints the file properly, but when I use
pdftocairo, the printer rejects the file with the following error:

Error name:   /configurationerror
Offending Command: --setpagedevice--
Operand Stack:

Even when removing _everything_ on the pdf, as the examples I have a
attached, I still get the "Offending Command" error.  I have tried
examining the content of the files, but I have a hard time pinpointing
what could be wrong in the pdftocairo-generated file.

I am attaching 3 additional files (A,B,C) that show attempts I made to
modify the file (thought maybe the page size/bounding box was the issue)
but all three have failed printing with the same error...

Anyone have ideas of what I should investigate?


poppler mailing list

Reply via email to