Jim Monroe wrote:

Terry- I've often experienced footprints that won't select when using 'inside area' unless I center their comments and designators as you describe. I didn't think that was what was being described.

He said that select inside "only highlights these parts optically, not really". I assumed that meant that the parts were highlighted in the selection color but that the selection attribute in the component dialog was not enabled.

Looks like the "Lock Primitives" is not checked. Hence he is able to select certain primitives of the component. However, when he tries to move, those primitives do not move because they are part of a component.

Here's the solution:

Double click on any component. Make sure that the "Lock Primitives" button is checked on the properties tab.

Click on "Global" to open the global section. Make sure that the "Lock Primitives" button is checked in the copy primitives column. Hit OK.

This will change all the components on the board to have their primitives locked. This way when you try and highlight, either the whole component will be highlighted or nothing. You may have to follow the previous posters' advice to get the designators and comments into close proximity to the component. If they are too far away, you will not be able to select the component using the "Select Inside" tool.

Hamid





* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* To post a message: mailto:[EMAIL PROTECTED]
*
* To leave this list visit:
* http://www.techservinc.com/protelusers/leave.html
*
* Contact the list manager:
* mailto:[EMAIL PROTECTED]
*
* Forum Guidelines Rules:
* http://www.techservinc.com/protelusers/forumrules.html
*
* Browse or Search previous postings:
* http://www.mail-archive.com/[EMAIL PROTECTED]
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Reply via email to