On Feb 19, 12:16 pm, Thomas Fuchs <[EMAIL PROTECTED]> wrote:
> Alternatively, we could add an "is" object to Object, and write:
>
> if(Object.is.array(blech)) { ... }
>
> or maybe (probably more true to current stuff in Prototype):
>
> if(Object.isArray(blech)) { ... }
>
> and/or:
>
> if(Object.class(blech) == 'Array') { ... }I think I like the "Object.isArray" style best so far. We must be careful with names like "Object.class", though -- "class" is reserved as a future keyword[1] by the ECMAScript spec. -- sam [1] http://developer.mozilla.org/en/docs/Core_JavaScript_1.5_Reference%3AReserved_Words --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Prototype: Core" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/prototype-core?hl=en -~----------~----~----~----~------~----~------~--~---
