Am 19.02.2007 um 19:00 schrieb Mislav Marohnić:
> On 2/19/07, Tobie Langel <[EMAIL PROTECTED]> wrote:
>
> (...)
>
> So there's another proposition I just though of, introducing the "is"
> namespace:
>
> Actually, I like your "is" namespace a lot! But - would the name be
> obtrusive? What if someone defines "is" variable in the global
> namespace (on the window object), will closures save subsequent
> calls to real "is" in the framework?
+1
Alternatively, we could add an "is" object to Object, and write:
if(Object.is.array(blech)) { ... }
or maybe (probably more true to current stuff in Prototype):
if(Object.isArray(blech)) { ... }
and/or:
if(Object.class(blech) == 'Array') { ... }
best,
thomas
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"Prototype: Core" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---