Install 2.16.3, this should fix GRASS problems.

> On Oct 11, 2016, at 8:07 AM, wkent <> wrote:
> I can run GRASS commands through the GRASS toolbox (using the GRASS plugin); 
> but I am unable to run them through the Processing Toolbox.  I get the "This 
> algorithm cannot be run :-(" error, and the QGIS log shows:
> 2016-10-11T09:02:12   0       GRASS GIS 7 execution console output
>                       /bin/sh: grass70: command not found
>                       /bin/sh: grass70: command not found
> I have set the paths in both the Processing Toolbox options, and the GRASS 
> Plugin options, to /Applications/
> In regards to the crash I get when trying to add an existing GRASS layer 
> (vector or raster) from the Browser panel to the Layers panel, the attached 
> text file is the crash report that was generated.
> Thanks so much for your help!
> On 2016-10-07 5:51 pm, William Kyngesburye wrote:
>> Loading GRASS data and using the GRASS toolbox are separate from using
>> GRASS "algorithms" in the Processing plugin.
>> The Processing plugin needs to know where GRASS is (set in Processing
>> options, but defaults to bundled GRASS 7), and runs GRASS commands in
>> a separate process than QGIS (should not crash QGIS).
>> Loading GRASS data in QGIS needs no configuration of a GRASS path
>> (this could crash QGIS if there is a bug or build problem).  Running
>> GRASS modules does need configuration, but this also defaults to the
>> bundled GRASS 7.  There is also a "general" GRASS option for the GRASS
>> installation path, but this seems to default to the compiled GRASS
>> location.  You can try setting this to the QGIS app:
>>  /Applications/
>> If you still get a crash, a copy of the crash log would help figure
>> out what's wrong.
>>> On Oct 7, 2016, at 1:30 PM, wkent <> wrote:
>>> On 2016-09-29 8:45 am, Howard Frederick wrote:
>>>> Recently upgraded to 2.16 - but cannot enable GRASS in the Processing 
>>>> configuration. Any ideas how to make this work?
>>>> The folder seems to be correctly indicated in the config: 
>>>> /Applications/
>>>> This (and alternatives like ending as grass7/ ) give "This algorithm 
>>>> cannot be run :-(".
>>>> Version: QGIS 2.16.2, on OS X 10.10.5.
>>> Same error here, except running OS X 10.11.6.  It seems to be a path issue, 
>>> although I have not been able to determine where the path is set.
>>> Additionally, while QGIS is able to locate and open my existing GRASS 
>>> locations/mapsets, when I click on a GRASS layer in the browser panel to 
>>> add to the layers panel, QGIS crashes.
>>> _______________________________________________
>>> Qgis-user mailing list
>>> List info:
>>> Unsubscribe:
>> -----
>> William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>
>> "Those people who most want to rule people are, ipso-facto, those
>> least suited to do it."
>> - A rule of the universe, from the HitchHiker's Guide to the Galaxy
> <qgis_2-16-2_crash_report_loading_grass_layer.txt>

William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>

"We can die but once, and that once we must die.  To be always fearing, then, 
would not avert it, and would make life miserable."

- Tarzan, on death

Qgis-user mailing list
List info:

Reply via email to