Dear list

I have been working with QGIS 2.14 and now 2.18 for a while on Linux Mint 17. Suddenly, I cannot open shape files any more. When trying to load them I get the message: "Layer is not valid: The layer XX.shp is not a valid layer and can not be added to the map." In the log message panel under ogr it says: "Data source is invalid (Unable to open XX.shx or XX.SHX.Try --config SHAPE_RESTORE_SHX true to restore or create it)"


Additionally, I cannot open GRASS files any more (which also used to work fine) and get the error:" Error reading database file from: /usr/share/qgis/resources/srs.db Because of this the projection selector will not work..." and then QGIS crashes.

Interestingly, I can open shape files from my file browser (it starts QGIS and loads the file) but then I cannot add another one. Raster (GeoTif) data are also fine.

I have no idea what's causing this. I have tried removing and reinstalling QGIS (version 2.18 and 2.14) without any success.

Can anybody give me any hint what might have corrupted my system?

Thanks a lot,
Mira

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to