On Tuesday, December 13, 2016 at 1:22:51 AM UTC+1, qubenix wrote:
> qubenix:
> > Marek Marczykowski-Górecki:
> >> On Mon, Dec 12, 2016 at 05:10:00PM +0000, qubenix wrote:
> >>> Marek Marczykowski-Górecki:
> >>>> Looks like this issue:
> >>>> https://github.com/QubesOS/qubes-issues/issues/2514
> >>>>
> >>>> Rebuilt package just uploaded to testing repository
> >>>> (qubes-gui-agent_3.2.10-2+deb9u1).
> >>>>
> >>>>
> >>
> >>> Doesn't seem to be fixed in stretch, stretch-testing, or
> >>> stretch-securitytesting yet.
> >>
> >>> ```
> >>> [user@dom0 ~]$ qvm-run -p d9 "sudo apt-get update && sudo apt-get
> >>> dist-upgrade -y"
> >>> Hit:1 http://vwakviie2ienjx6t.onion/debian stretch InRelease
> >>> Hit:2 http://sgvtcaew4bxjd7ln.onion stretch/updates InRelease
> >>> Hit:3 http://deb.qubes-os.org/r3.2/vm stretch-testing InRelease
> >>> Hit:4 http://deb.qubes-os.org/r3.2/vm stretch-securitytesting InRelease
> >>> Reading package lists...
> >>> Reading package lists...
> >>> Building dependency tree...
> >>> Reading state information...
> >>> Calculating upgrade...
> >>> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> >>> [user@dom0 ~]$ qvm-run -p d9 "sudo dpkg -l" | grep qubes-gui
> >>> ii qubes-gui-agent 3.2.8+deb9u1 amd64 Makes X11 windows available to
> >>> qubes dom0
> >>> ```
> >>
> >> Interesting, I have qubes-gui-agent 3.2.11 already, from
> >> stretch-testing. Do you have some caching proxy in between?
> >>
> > At one point I was using Rustybirds update cache proxy, but I've since
> > switched back to a whonix-gw and unchecked "Allow connections to Updates
> > Proxy".
> > 
> > I have two debian-9 templates, and they both were connected to update
> > cache and are now connected to whonix-gw. Here's the results from my two
> > debian-9 templates (one is using stretch-testing and
> > stretch-securitytesting the other has only stretch-testing although I
> > don't think that should matter):
> > 
> > ```
> > [user@dom0 ~]$ qvm-run -p d9 "sudo apt-get update && sudo apt-get
> > dist-upgrade -y -V"
> > Hit:1 http://vwakviie2ienjx6t.onion/debian stretch InRelease
> > Hit:2 http://sgvtcaew4bxjd7ln.onion stretch/updates InRelease
> > Hit:3 http://deb.qubes-os.org/r3.2/vm stretch-testing InRelease
> > Hit:4 http://deb.qubes-os.org/r3.2/vm stretch-securitytesting InRelease
> > Reading package lists...
> > Reading package lists...
> > Building dependency tree...
> > Reading state information...
> > Calculating upgrade...
> > 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> > [user@dom0 ~]$ qvm-run -p d9-kali "sudo apt-get update && sudo apt-get
> > dist-upgrade -y -V"
> > Hit:1 http://vwakviie2ienjx6t.onion/debian stretch InRelease
> > Hit:2 http://sgvtcaew4bxjd7ln.onion stretch/updates InRelease
> > Hit:3 http://deb.qubes-os.org/r3.2/vm stretch-testing InRelease
> > Hit:5 http://deb.bitmask.net/debian stretch InRelease
> > Hit:4 http://archive-3.kali.org/kali kali-rolling InRelease
> > Reading package lists...
> > Reading package lists...
> > Building dependency tree...
> > Reading state information...
> > Calculating upgrade...
> > The following packages have been kept back:
> >    qubes-gui-agent (3.2.8+deb9u1 => 3.2.11-1+deb9u1)
> > 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
> > [user@dom0 ~]$ qvm-run -p d9-kali "sudo aptitude dist-upgrade"
> > Reading package lists...
> > Building dependency tree...
> > Reading state information...
> > Reading extended state information...
> > Initializing package states...
> > Building tag database...
> > The following NEW packages will be installed:
> >   xserver-xorg-input-qubes{ab} xserver-xorg-video-dummyqbs{ab}
> > The following packages will be upgraded:
> >   qubes-gui-agent
> > 1 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
> > Need to get 66.5 kB of archives. After unpacking 36.9 kB will be used.
> > The following packages have unmet dependencies:
> >  xserver-xorg-video-dummyqbs : Depends: xorg-video-abi-23 which is a
> > virtual package, provided by:
> >                                         - xserver-xorg-core
> > (2:1.19.0-2), but 2:1.18.4-2 is installed
> > 
> >                                Depends: xserver-xorg-core (>=
> > 2:1.18.99.901) but 2:1.18.4-2 is installed
> >  xserver-xorg-input-qubes : Depends: xorg-input-abi-24 which is a
> > virtual package, provided by:
> >                                      - xserver-xorg-core (2:1.19.0-2),
> > but 2:1.18.4-2 is installed
> > 
> >                             Depends: xserver-xorg-core (>=
> > 2:1.18.99.901) but 2:1.18.4-2 is installed
> > The following actions will resolve these dependencies:
> > 
> >      Keep the following packages at their current version:
> > 1)     qubes-gui-agent [3.2.8+deb9u1 (now)]
> > 2)     xserver-xorg-input-qubes [Not Installed]
> > 3)     xserver-xorg-video-dummyqbs [Not Installed]
> > 
> > 
> > 
> > Accept this solution? [Y/n/q/?]
> > ```
> > 
> I fixed the second template (d9-kali) by issuing:
> 
>     sudo apt-get install -t stretch xserver-xorg-core
>     sudo apt-get dist-upgrade
> 
> That fixed my dependency problem and upgraded/installed the 3 packages.
> Still, though, my d9 template is acting as though there is no package to
> upgrade.
> 
> -- 
> qubenix
> GPG: B536812904D455B491DCDCDD04BE1E61A3C2E500

thanks, this was the issue for me as well.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/94997d39-2302-4c94-9aa1-ffee6f639bb1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to