On Mon, Feb 19, 2018 at 05:44:44AM -0800, snowboard...@gmail.com wrote:
> On Monday, February 19, 2018 at 2:36:08 PM UTC+1, Yuraeitha wrote:
> > On Monday, February 19, 2018 at 1:20:24 PM UTC+1, snowbo...@gmail.com wrote:
> > > I feel like a total idiot here but here is what I am doing:
> > > 
> > > 1) I make an HVM (tried both normal and template) and then assign more 
> > > disk space to it. 
> > > 2) I download the ubuntu iso file for desktop.
> > > 3) I run qvm-start ubuntu --cdrom=vmpath:/home/user/downloads/xxx.iso
> > > 4) I run the installation that surprisingly finishes ultra fast. There 
> > > are two disks one is xvda and xvdb. The first has the space that VM has 
> > > for "personal usage" and the second for "system". I tried installing on 
> > > both with same result.
> > > 5) As the installation finishes when I shutdown the machine it doesn't 
> > > shutdown. A black window keeps on. Then I kill it with Qubes-manager.
> > > 6) after that it doesn't start. It says booting from hard drive but 
> > > nothing happens.
> > > 
> > > I tried many times. What am I doing wrong?
> > > 
> > > thanks in advance
> > 
> > Don't label yourself as an idiot. Although I'm not an expert, but your 
> > logical approach seems pretty good to me, you try to find the reason and 
> > logic behind it. No matter what, trying to solve it is a good logical 
> > quality.
> > 
> > As for why it doesn't work, it seems like a driver issue for graphics? You 
> > could try change the AppVM's grub menu, and put a different graphic driver, 
> > xdriver=vesa, nomodeset, or something along those lines. Vast topics can be 
> > found on this issue, now that you can suspect graphiic issues, you can more 
> > easily find these topics to try troubleshoot it if neither commands above 
> > work.
> > 
> > You can also try change the used kernel to '' blank, since Ubuntu custom 
> > install without Qubes code, probably has no means to use its own kernel 
> > pulled from dom0 kernels, and the Ubuntu kernel may try to boot up while 
> > the VM kernel's located in dom0. As such, there may be a conflict here? I'm 
> > not sure if this is what is happening, but you can try put the qvm-prefs 
> > for the kernel in blank, install again and see what happens, it should 
> > allow Ubuntu to use its own kernel, I believe.
> > 
> > btw, for what purposes are you getting Ubuntu? By any chance is it codecs? 
> > are the other reasons? It may be more efficient to fix up Fedora or Debian, 
> > instead of getting Ubuntu up and running. It's just that there are so many 
> > Ubuntu questions lately, I'm a bit lost as to why people would want Ubuntu 
> > if they installed Qubes OS. Qubes OS is a bit of a leap to jump from 
> > Ubuntu, Debian or Fedora isn't that bad for next steps after Ubuntu, but 
> > Qubes OS may be a bit of a leap in its current state. 
> > 
> > The only real nice thing is the ease to install nvidia drivers, but that is 
> > hardly something you will end up needing in Qubes anyway. Can I ask what 
> > you need Ubuntu for? and perhaps if you desire to give it a shot for an 
> > alternative, and try Fedora and Debian to get the tasks done you usually do 
> > on Ubuntu? If you still feel like going for Ubuntu, then that's fine, I 
> > won't get in the way for that. 
> > 
> > As such, if keeping Ubuntu, fixing graphic drivers may be a good place to 
> > start here?
> Hi thanks I will try that. I am using Ubuntu because Debian 8 is such a pain 
> when installing new software. You need to enable testing and unstable repos 
> and then you end up with a mixed system then things break down etc. Ubuntu 16 
> is for sure compatible with most software oob for the next 2 years. 

Can you try again, just installing to the first disk?(xvda)
Also, make sure that you have enough memory allocated:
qvm-prefs <qube> -s memory 8192
qvm-prefs <qube> -s maxmem 8192

You're doing the right thing, and as you can boot from the iso all
should be fine. There are issues with Ubuntu resolution when running as
VM - you can see reference to this in the list in the past. Changing
graphics drivers wont help with that issue.

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to