'awokd' via qubes-users:
duc...@disroot.org:
This is an issue that's been reported before, and some solutions appear
to be out there, including re-installing with Legacy boot. However, they
all seem to involve modifying the installer prior to installation or
making changes via a GRUB menu. I'm never presented with a GRUB menu
with either (I suspect that's a UEFI issue), so I'm not quite sure how
to proceed with troubleshooting.  I want to stick with UEFI-only boot as
far as possible.

The last messages echoed before the black screen are:

[VT-D]Passed iommu=no-igfx option.  Disabling IGD VT-d engine.
Scrubbing Free RAM on 1 nodes using 2 CPUs
.................done.
Initial low memory virq threshold set at 0x4000 pages.
Std. Loglevel: All
Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
Xen is relinquishing VGA console.

The screen goes black indefinitely at this point.

This is a device with only integrated GPU so I suspected this might be a
problem.

How should I proceed?

Intel integrated GPU usually works well as is. Are you getting the black
screen when you boot the installer, or after it completes and reboots?


For what it's worth, yesterday I updated dom0 on a previously working Qubes 4.0.1 installation, rebooted, and ran into this exact problem. I have absolutely no idea if it's related.

Also, re: grub, from my experience it appears to me that it only uses grub.efi if you have more than one OS installed, such as R4.0.1 and R4.1, otherwise xen.efi is used which does not have any boot menu or command line capabilities. I imagine you could change this from rescue media using some kind of UEFI boot config utility, or perhaps by running grub-install? With rescue media, you also can modify boot parameters in /boot/xen.cfg directly.

In my case, changing xen.cfg back to 4.14 kernel seems to solve the issue, but I know I had a 4.19 kernel working on this same machine before. I haven't tried legacy boot at all.

Anyway, point is that it may not be strictly due to UEFI, per se. For me, 4.14 worked fine under UEFI, and then the 4.19 update caused the same symptoms you're seeing, which is just like any other update-gone-wrong, UEFI or not. Also, I don't even know if it was the kernel update that caused it. It could have been caused by a dracut update, Xen, or anything else, I assume.

It's on a currently non-production system so I'm probably not going to troubleshoot it. Most likely I'll wait around for the next kernel update and see if that fixes it, or wait around for 4.0.2 and reinstall and see if that fixes it.

-------------------------------------------------
This free account was provided by VFEmail.net - report spam to ab...@vfemail.net

ONLY AT VFEmail! - Use our Metadata Mitigator to keep your email out of the 
NSA's hands!
$24.95 ONETIME Lifetime accounts with Privacy Features! 15GB disk! No bandwidth quotas! Commercial and Bulk Mail Options!
--
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/591e6cc2-8728-4d34-96d1-03fa80869d6e%40vfemail.net.

Reply via email to