I performed your test with a clone of fedora-37 template.  I did get a 
dialog window requesting me to select the program to use to open the pdf 
file.  It did not remember the /usr/bin/evince path the next time after I 
browsed to it and checked the remember box when opening the pdf the first 

I did not get the same error message you did when I launched krusader from 
cli.  I got the following error messages

kf.i18n: KLocalizedString: Using an empty domain, fix the code. msgid: "No 
jobs" msgid_plural: "" msgctxt: ""

(krusader:2530): Gdk-CRITICAL **: 10:23:45.254: gdk_atom_intern: assertion 
'atom_name != NULL' failed

(krusader:2530): Gdk-CRITICAL **: 10:23:45.255: gdk_atom_intern: assertion 
'atom_name != NULL' failed
10:23:45.446-warning kf.i18n unknown@0 # Trying to convert empty 
KLocalizedString to QString.

When I first launched krusader I got a popup warning with the following 
No text editor plugin available
Internal editor will not work without this.
You can fix this by installing Kate:

After I installed kate in the appVM, just to see what would happen, I got 
the following message after loading krusader and opening the pdf the first 
time but not subsequent times.
10:43:29.756-critical default unknown@0 # "applications.menu"  not found in 

On Monday, April 24, 2023 at 3:02:42 AM UTC-7 Qubes wrote:

> I am trying to get to the bottom of a problem but I need someone, 
> perhaps more than one someone, to do a small test for me to confirm 
> whether my problem is specific for me to my system or if this is a 
> general issue. I have a problem description and test request which 
> should only take a couple of minutes (1. clone template, 2. sudo dnf 
> install krusader, 3. open file from appVM using Krusader).
> I have Krusader installed on a Debian 10/11 machine without any issues, 
> but, if I install Krusader on Fedora 36/37 it does not have any file 
> type associations. Which means whenever I double click, or press enter, 
> on a file it brings up the dialog window where I am supposed to be able 
> to select a program to use for the file type I am opening. This window 
> does not display any programs, which is still ok (but not normal) I can 
> point it to the program in /usr/bin to use, the problem then continues 
> in that Krusader does not save this (yes I do select the checkbox for it 
> to remember).
> I have also tried right clicking on a file and selecting Properties, 
> from there I select the Change button next to Open With, but the same 
> happens here, my selection does not stick.
> If I launch Krusader from cli I get the following output on the cli 
> window when I double click a file (when the dialog opens where I should 
> select the program to use), “15:08:53.325-warning kf.service.services 
> unknown@0 # KServiceFactory: unexpected object entry in KSycoca database 
> (type= 305 )”.
> I am almost certain this is because of a missing dependency but I cannot 
> figure out what dependency it is. Can anyone help with this?
> == TO TEST ==
> I use the minimal template for all of my configs, but to rule out any 
> underlying issue with the minimal template I suggest using the Fedora 
> 36/37 template. I did the same.
> 1. Clone template
> 2. sudo dnf install krusader
> 3. create appVM based on above template
> 4. copy a pdf document to the appVM
> 5. open the pdf from Krusader
> Do you also get a dialog window requesting you to select the program to 
> use to open the file and it is empty? Or does your program list include 
> evince? If you type in the location to the program (either just "evince" 
> or /usr/bin/evince") and click to "remember", does it remember or do you 
> get the same empty program list selection window when you open the pdf 
> again?
> Finally, do you also see the "warning kf.service.services unknown@0 # 
> KServiceFactory: unexpected object entry in KSycoca database (type= 305 
> )” when you launch Krusader from cli?
> == END TEST ==

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to