I am trying to install radiance on Linux 64 (in a docker container based on

When I run ‘makeall install’ I get 10 errors of the following type: *fatal
error: *X11/Xlib.h: No such file or directory

I believe this is because I don’t have X11 installed. I have a /usr/lib64/X11
directory but it is empty.

There is a library for amazonlinux called libX11 (https://aws.amazon.com/
amazon-linux-ami/2017.09-packages/), so I installed it: yum install

I can ask what was installed:

sh-4.2# repoquery --list libX11










How do I now change the -L option of the rmake command to reflect my

The current value is  ‘-L/usr/X11R6/lib’

I tried changing it to ‘-L/usr/lib64’  but I still get the X11-related
fatal errors.

I also tried copying the libX11 files from /usr/lib/ to /usr/lib64/X11 and
setting -L to '-L/usr/lib64/X11' but I get the same errors.

Have you come across this problem before?

Any suggestions as to how to address the problem?

Thank you in advance for your help.

Philip Schwarz
Radiance-dev mailing list

Reply via email to