William Ross schrieb:
On 21 Jul 2010, at 20:18, Jim Gay wrote:

On Wed, Jul 21, 2010 at 4:09 PM, Horst Rischbode <ho...@horibo.de> wrote:
Hi,

this doesn't seem to be a windows issue. Here is the log entry. This comes
up each time, a thumbnail or icon image should be built.

[paperclip] identify '-format' '%wx%h'
'C:/DOCUME~1/horibo/LOCALS~1/Temp/stream,3296,0.jpg[0]' 2>NUL
[paperclip] An error was received while processing:
#<Paperclip::NotIdentifiedByImageMagickError:
C:/DOCUME~1/horibo/LOCALS~1/Temp/stream,3296,0.jpg is not recognized by the
'identify' command.>

Any help would be appreciated! Thanks!
It looks like this is an error from Paperclip.
I don't know enough about it and windows to give you any help. You
might want to try the paperclip mailing list
http://groups.google.com/group/paperclip-plugin


That error usually means that imagemagick can't be found, which again is 
usually because only a restricted path is available to your application. In 
that case the easy fix is to set Paperclip.options[:command_path] in an 
initializer. You get the same thing under passenger, and for that I use this:

Paperclip.options[:command_path] = IMAGE_MAGICK_PATH
So that IMAGE_MAGICK_PATH can be set differently for each environment.

will
Will, thanks for that. The call of 'identify' changes and includes the correct path. The error messages remain the same. Trying to call identify from the command line succeeds. Call with my test image delivers the expected results... Strange...

Horst

Reply via email to