I feel like my question is very naive too, so naive questions are
welcome. :)

I ran "script/server" one time and it didn't have any effect. Because
I'm trying to get this working on a shared server environment, it's
setup so that the rails server is always running. Because it's shared
hosting I don't really have any control over what mode the server is
running in. It's probably always in production mode and I tried
scraping the production db and even though that ran successfully I was
still unable to get to the admin pages.

On Oct 3, 8:59 am, Mohit Sindhwani <t...@onghu.com> wrote:
>   On 3/10/2010 7:40 PM, Jonathan wrote:
> > Yes. I'll be more specific.
> > I had my hosting company install the radiant gem.
> > I logged into a terminal and ran "radiant --database=mysql radiant-
> > test"
> > That created the folder radiant-test with a few files but no app
> > folder for adding views and controllers
> > I configured my database.yml file to connect to my  MySQL database and
> > ran "rake development db:bootstrap"
> I'm sorry if this is a naive question..
> but did you start a Rails server to serve the Radiant app?
> Also, you did rake development - are you running the server in
> development mode or production mode?
> Most of the time, Radiant is run in production mode - even if you are
> _developing_ content, it doesn't mean that Radiant needs to run in
> development mode... the application runs in production.
> > I created my administrator and then chose "Styled Blog"
> > Everything came back with an OK and then it was finished.
> > To me it all looked successful.
> > So, I went to the URL to log in to the backend and got a 404.
> Cheers,
> Mohit.
> 3/10/2010 | 8:58 PM.

Reply via email to