When you say rendering with no assets, are you expecting that the Asset Manager automatically knows about images, etc. in your app., because it doesn't.

What do you expect to see that you aren't seeing? Please be specific.

W

On 9/1/11 2:11 PM, Dave wrote:
Hi Wes,

Inspiring. I know it works now too. I am puzzled though about why the
Admin is rendering with no assets. I am using the same technique as
you... I need to play more with this system obviously but it is
frustrating... glad I am on the right track now though...

I know those assets exist in heroku... Radiant routes are somehow not
finding them though.

Thanks!


On Sep 1, 3:04 pm, Wes Gamble<we...@att.net>  wrote:
Dave,

I'm currently running Radiant 1.0.0 RC2 on Rails 2.3.11 on Heroku
without incident, using Radiant as a gem and not installing it to
vendor/radiant.

I created the app. using the "radiant" app generator command, so, for
example, I don't have an "app" directory.

Here's my Gemfile:

source :gemcutter

# bundler requires these gems in all environments
gem 'acts_as_list'
gem 'awesome_nested_set', '= 1.4.4'
gem 'aws-s3',           :require =>  'aws/s3'
gem 'compass',          '~>  0.10.6'
gem 'delocalize',       '~>  0.2.3'
gem 'devise',           :path =>  'vendor/gems'
gem 'fancy-buttons'
gem 'haml',             '~>  3.0.24'
gem 'hoptoad_notifier'
gem 'paperclip',        '= 2.3.3'
gem 'radiant',             '= 1.0.0.rc2'
gem 'rails',               '= 2.3.11'
gem 'rest-client'
gem 'uuidtools'
gem 'warden'

# bundler requires these gems in development
group :development do
    gem 'heroku'
    gem 'sqlite3-ruby',       :require =>  'sqlite3'
    gem 'taps'
end

# bundler requires these gems while running tests
group :test do
    gem 'cucumber-rails'
    gem 'database_cleaner'
    gem 'webrat'
    gem 'rspec'
    gem 'rspec-rails',        '= 1.3.2'
end

Wes

On 9/1/11 11:56 AM, Dave wrote:







Hi,
I am trying to run on Heroku. I usually stick to Sinatra projects
where I write all the code, and am using Ruby 1.9.2 and latest gems
for everything.
I have a client that needs Radiant CMS for a project. I see Radiant is
still Rails 2.x and Ruby 1.8.7 amongst other things.
I have tried out the instructions on the wiki to run Radiant on
Heroku, but the wiki leads to a dead end. I am using REE for the
1.8.7. following the instructions leads to all sorts of errors due to
the use of old gems, deprecated methods etc.
Is there a reliable document somewhere, where a trusty install of this
codebase can be made to heroku...
The existing wiki article steps that result in a mess are:
git clone git://github.com/radiant/radiant.git vendor/radiant
cd vendor/radiant
git submodule init
git submodule update
rm -rf `find . -name .git`
rm .gitmodules
The submodules do not seem to initialize to anything useful. There are
no .gitmodules to remove. And further, trying to run rake gems:install
bombs out on a faulty Radiant install and deprecation notices about
rdoc...and rack/cache.
Quite  a mess...
Is there a nice bundler compatible Gemfile around that would allow a
nice Heroku PostgreSQL Radiant CMS to be deployed with HAML
templates???
Just curious... seems like a nice system...

Reply via email to