Hi Scott, On 6/10/26 9:51 AM, Scott Hollenbeck wrote: > This is why I don't understand how extension identifiers for EPP and RDAP > can't follow a similar, simple convention. We could agree that, for example, > a draft RDAP extension should be identified by a string of the form > "draft_<unique name>_<draft number>. Using the sample example from above for > an initial version, draft_foo_0. Every time the draft/specification changes, > the identifier is incremented just as the draft number is incremented. Draft > implementation can happen, and servers can announce support for specified > draft versions using these unique identifiers. Clients can choose the draft > versions they wish to implement using the same identifiers. There's no need > to worry about breaking changes because every version of a specification is > associated with a unique identifier. Clients and servers use those > identifiers when sending and receiving information, and mismatches in > implementation are ignored or flagged appropriately. When a draft becomes an > RFC, a final identifier (foo_0) is defined by removing "draft" and resetting > the version number.
Section 2.2 of draft-ietf-regext-rdap-extensions no longer allows the use of underscore in the extension identifier to help with ambiguities of its use as a separator between the ext id and the rest of whatever identifier it is attempting to namespace. And camelcase is recommended for readability. So it would be "draftFoo0". Section 2.2 also reserves ext ids with "ietf" and "example". If it is important to people to have ext ids just for drafts, we could also reserve "draft" too. How does that sound? -andy, no hats _______________________________________________ regext mailing list -- [email protected] To unsubscribe send an email to [email protected]
