Perhaps packages which provide middleware functionality should be
named ``wsgi.*``, e.g. ``wsgi.bitblt`` or ``wsgi.who`` and we'd opt
similar namespaces for packages that belong to other realms.
I'm not sure this ``repoze.*`` notion is very healthy in terms of
getting traction outside the Zope-community, although .what and .who
have gained some popularity in spite of their nebulous namespace.
What's the feeling on brand-like names such as ``WebOb``, or
``Routes``? That might be the right approach for more conceptual
packages. At least that's my motivation for naming the new package
``Chameleon``. I think .who might fall in this category, not being
just a library, but something more conceptual, e.g. ``Who``.
Repoze-dev mailing list