-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Nathan Van Gheem wrote:

> I'm having some very odd behavior with using repoze.zope2. The site is being
> served using repoze.vhm#vhm_xheaders filter. The correct site is served;
> however, it seems that content editors can not see the content actions drop
> down menus(Actions, Display, Add new..., etc). More specially, when using
> repoze.vhm, the "plone.contentactions" viewlet will *NOT* be called on any
> page except the home page.
> 
> If I remove the repoze.vhm filter, the issue does not occur. I have not dug
> too deep into the issue yet. I kind of wanted to post here and see if anyone
> else has seen this issue and if there is something simple I may be doing
> wrong.

I don't have ay idea how that viewlet is implemented:  is it possible
that it makes an invalid JSON / XML-RPC call when the virtual hosting is
in place?  Can you see anything in Firebug about a failed request?  What
does render at that point in the page?


Tres.
- --
===================================================================
Tres Seaver          +1 540-429-0999          tsea...@palladion.com
Palladion Software   "Excellence by Design"    http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAks3oN0ACgkQ+gerLs4ltQ5bkgCgt1AwOCoN45hXrp1o1OIBs0QE
0fIAnRjTbfeVhLyX7OlWknevquXrPp09
=53zA
-----END PGP SIGNATURE-----
_______________________________________________
Repoze-dev mailing list
Repoze-dev@lists.repoze.org
http://lists.repoze.org/listinfo/repoze-dev

Reply via email to