How are you passing the arguments to the JVM?  In Resin 3.0, that was
done with specifying "args" in  In Resin 3.1 you need to
specify the arguments in resin.conf as shown here:





[mailto:[EMAIL PROTECTED] On Behalf Of MORAWETZ Martin
Sent: Tuesday, August 14, 2007 7:09 AM
To: General Discussion for the Resin application server
Subject: [Resin-interest] Debugging Resin Apps in/with Eclipse



I had two approaches to debug Resin Apps within Eclipse 
which worked for me perfectly with Resin 3.0.x. However 
with Resin 3.1.2 I can't get them to work. 

The first approach was to start Resin with the arguments 
-Xdebug -Xnoagent 
and have in Eclipse Resin as Remote Application configured 
(Run -> Debug -> Remote Application), connection Type Socket. 

The second approach was to start Resin in Eclipse having 
Resin configured as 'Java Application'. To switch from Resin 
3.0.x to Resin 3.1.2 I just had to change the classpath and 
change the main class from 
'com.caucho.server.http.ResinServer' to 
'com.caucho.boot.ResinBoot' (I guess). 

Both approaches show the same result with Resin 3.1.2. 
I see the Resin threads in the debug perspective as usual, I'm able 
to run the application, but Breakpoints don't get recognized 
hence I'm not able to debug. 

Any Ideas? 

Regards Martin 

resin-interest mailing list

Reply via email to