I realize you've solved your problem, but I thought I'd share a  
similar slow-startup problem that we ran across that I would have  
suggested had I looked at the thread earlier. Adding here so that it  
makes it into the archives.

One of our apps allowed users to upload files. These files were  
stored in a directory that was deep within the WEB-INF directory of  
the webapp. As the number of files grew very large (100's of  
thousands), we found that the webapp was taking longer and longer to  
startup. Later we found that at startup time, resin was doing a  
search through all WEB-INF subdirectories for any taglib files. I  
don't know if this was a misconfiguration on our part or just normal  
behavior. Our simple solution was to put the directory of uploaded  
files elsewhere and keep the number of files inside WEB-INF to a  
reasonable number.

This may not apply to all versions of resin (we made that change in  
the resin 2.x days) but it's just another potential slow startup  
scenario for future reference.


On Oct 8, 2007, at 6:39 AM, Mattias Jiderhamn wrote:

> I believe I have found the offender in this issue: ZoneAlarm.
> I had already tried to turn it off, but since I have seen some strange
> behaviour with ZoneAlarm before I now tried uninstalling it  
> altogether.
> That seem to have solved the issue.
> I'm sorry for wasting your time, especially now that I remember I
> probably upgraded ZoneAlarm (free version to 7.0.408) around the time
> the problems started. *blush*
> Thanks for all the tips and suggestions - the supportive community is
> part of what makes Resin great.
> Hopefully the archive copy of this thread can be of help to  
> somebody else.
>  /Mattias
> I wrote:
>> By the way, the CPU usage is peaking all the way through. Around  
>> 49% on
>> my dual core system.
>> (And there is even more memory on the computer with the problem  
>> than the
>> other one)
>>> -----Original Message-----
>>> [mailto:[EMAIL PROTECTED] Behalf Of Mattias  
>>> Jiderhamn
>>> Sent: Friday 05 October 2007 11:20
>>> To: Resin
>>> Subject: [Resin-interest] Slooow file reads (really weird!)
>>> Hi list.
>>> I have my J2EE webapp on an external hard drive, which I carry  
>>> between
>>> my office and my home computer.
>>> On each computer - running Windows XP and Java 1.5 - I have a Resin
>>> (3.0.22) installation and a shortcut to start Resin with the  
>>> server root
>>> on the external drive.
>>> This has worked flawlessly for over a year.
>>> Now suddenly (ok, after returning from vacation), the application is
>>> immensely slow - on one of the computers!
>>> Starting Resin and the application now takes anywhere from 3 to 5
>>> minutes on my home computer, compared to the usual 30 or so seconds.
>>> Loading a simple page can take 40 seconds. It seems that most of the
>>> time is spent inside the disk access of the dependency checking.
>>> (Turning dependency checking off was much faster, but still  
>>> slower than
>>> normal).
>>> I tried to copy the project to the internal drive to see if there  
>>> was
>>> some interface hardware issue - no difference.
>>> I profiled the application with JProfiler, and it thinks there is a
>>> hotspot in com.caucho.vsf.JniStream.read(). Why...?
>>> I am running out of ideas on what could be wrong and how to track  
>>> it down.
>>> Any tips would be much welcome!
>>>   /Mattias
> _______________________________________________
> resin-interest mailing list
> resin-interest@caucho.com
> http://maillist.caucho.com/mailman/listinfo/resin-interest

resin-interest mailing list

Reply via email to